about summary refs log tree commit diff
path: root/include
Commit message (Collapse)AuthorAgeFilesLines
* SOL_TCP is nonstandard and not in the reserved namespaceRich Felker2013-01-311-2/+1
| | | | | | | | | | alternatively, we could define it in sys/socket.h since SO* is reserved there, and tcp.h includes sys/socket.h in extensions mode. note that SOL_TCP is simply wrong and it's only here for compatibility with broken applications. the correct argument to pass for setting TCP socket options is IPPROTO_TCP, which of course has the same value as SOL_TCP but works everywhere.
* add RTLD_NODELETE flag for dlopenRich Felker2013-01-231-0/+1
| | | | | | this is a trivial no-op, because dlclose never deletes libraries. thus we might as well have it in the header in case some application wants it, since we're already providing it anyway.
* add support for RTLD_NOLOAD to dlopenRich Felker2013-01-231-0/+1
| | | | | | | | based on patch by Pierre Carrier <pierre@gcarrier.fr> that just added the flag constant, but with minimal additional code so that it actually works as documented. this is a nonstandard option but some major software (reportedly, Firefox) uses it and it was easy to add anyway.
* use a common definition of NULL as 0L for C and C++Rich Felker2013-01-188-49/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | the historical mess of having different definitions for C and C++ comes from the historical C definition as (void *)0 and the fact that (void *)0 can't be used in C++ because it does not convert to other pointer types implicitly. however, using plain 0 in C++ exposed bugs in C++ programs that call variadic functions with NULL as an argument and (wrongly; this is UB) expect it to arrive as a null pointer. on 64-bit machines, the high bits end up containing junk. glibc dodges the issue by using a GCC extension __null to define NULL; this is observably non-conforming because a conforming application could observe the definition of NULL via stringizing and see that it is neither an integer constant expression with value zero nor such an expression cast to void. switching to 0L eliminates the issue and provides compatibility with broken applications, since on all musl targets, long and pointers have the same size, representation, and argument-passing convention. we could maintain separate C and C++ definitions of NULL (i.e. just use 0L on C++ and use (void *)0 on C) but after careful analysis, it seems extremely difficult for a C program to even determine whether NULL has integer or pointer type, much less depend in subtle, unintentional ways, on whether it does. C89 seems to have no way to make the distinction. on C99, the fact that (int)(void *)0 is not an integer constant expression, along with subtle VLA/sizeof semantics, can be used to make the distinction, but many compilers are non-conforming and give the wrong result to this test anyway. on C11, _Generic can trivially make the distinction, but it seems unlikely that code targetting C11 would be so backwards in caring which definition of NULL an implementation uses. as such, the simplest path of using the same definition for NULL in both C and C++ was chosen. the #undef directive was also removed so that the compiler can catch and give a warning or error on redefinition if buggy programs have defined their own versions of NULL prior to inclusion of standard headers.
* add MOD_TAI to sys/timex.h and update STA_RONLYSzabolcs Nagy2013-01-121-1/+2
|
* add SWAP_FLAG_DISCARD to sys/swap.hSzabolcs Nagy2013-01-121-0/+1
|
* add mount flags to sys/mount.hSzabolcs Nagy2013-01-121-4/+22
| | | | | | | | added various MS_*, MNT_*, UMOUNT_* flags following the linux headers, with one exception: MS_NOUSER is defined as (1U<<31) instead of (1<<31) which invokes undefined behaviour the S_* flags were removed following glibc
* add IN_EXCL_UNLINK to sys/inotify.hSzabolcs Nagy2013-01-121-0/+1
|
* add EPOLLWAKEUP flag to sys/epoll.hSzabolcs Nagy2013-01-121-0/+1
|
* add RB_SW_SUSPEND and RB_KEXEC to sys/reboot.hSzabolcs Nagy2013-01-121-0/+2
| | | | using the glibc names for the magic constants of the linux reboot syscall
* add missing ptrace requests and options to sys/ptrace.hSzabolcs Nagy2013-01-121-1/+9
|
* add missing multicast socket options to netinet/in.hSzabolcs Nagy2013-01-121-0/+17
| | | | | | based on linux headers add the missing MCAST_* options under _GNU_SOURCE as they are not in the reserved namespace (this api was originally specified by RFC 3678)
* add missing protocol families to sys/socket.hSzabolcs Nagy2013-01-121-1/+11
| | | | | missing protocol families based on current linux headers: PF_RDS, PF_LLC, PF_CAN, PF_TIPC, PF_NFC
* fix another case of cloexec/nonblock flags not matching arch valuesRich Felker2013-01-101-2/+3
|
* setjmp.h: add struct tag for sigjmp_buf (GCC C++ compatibility)rofl0r2013-01-041-1/+1
| | | | | | | | | | | | | | the anonymous struct typedef with array notation breaks with GCC in C++ mode: error: non-local function 'static<anonymous struct> (& boost::signal_handler::jump_buffer())[1]' uses anonymous type this is a known GCC issue, as search results for that error msg suggest. since this is hard to work around in the calling C++ code, a fix in musl is preferable.
* add legacy header values.hrofl0r2013-01-042-0/+40
| | | | | | | | | some programs (procps, babl) expect it, and it doesn't seem to cause any harm to just add it. it's small and straightforward. since math.h also defines MAXFLOAT, we undef it in both places, before defining it.
* time.h: add BSD aliases for otherwise internal struct tm membersrofl0r2013-01-041-0/+4
|
* wait.h: add linux specific, thread-related waitpid() flagsrofl0r2013-01-041-0/+4
| | | | | | | | | these flags are needed in order to be able to handle lwp id's which the kernel returns after clone() calls for new threads via ptrace(PTRACE_GETEVENTMSG). fortunately, they're the same for all archs and in the reserved namespace.
* __assert_fail(): remove _Noreturn, to get proper stacktracesrofl0r2013-01-041-1/+1
| | | | | | | | for _Noreturn functions, gcc generates code that trashes the stack frame, and so it makes it impossible to inspect the causes of an assert error in gdb. abort() is not affected (i have not yet investigated why).
* add some new-ish IPPROTO constants that were missingRich Felker2013-01-011-0/+3
|
* expose [v]asprintf under _BSD_SOURCERich Felker2012-12-281-2/+2
| | | | reported/requested by Strake; simplified from the provided patch
* align EPOLL_* flags with fcntl O_* flag definitions, which vary by archRich Felker2012-12-271-2/+3
| | | | | | | | the old definitions were wrong on some archs. actually, EPOLL_NONBLOCK probably should not even be defined; it is not accepted by the kernel and it's not clear to me whether it has any use at all, even if it did work. this issue should be revisited at some point, but I'm leaving it in place for now in case some applications reference it.
* add linux extension POLLRDHUP to poll.hRich Felker2012-12-261-0/+1
| | | | | the POLL prefix is in the reserved namespace for poll.h, so no feature test macro checks are needed.
* merge a few fixes by sh4rm4Rich Felker2012-12-193-0/+22
|\
| * socket.h: add SO_(SND/RCV)BUFFORCE to generic blockrofl0r2012-12-191-0/+2
| |
| * add inet_network (required for wine)rofl0r2012-12-191-0/+1
| |
| * link.h: expose glibc/svr4 dynlinker debugging gluerofl0r2012-12-191-0/+19
| | | | | | | | | | | | this is already implemented in the dynliker (see struct debug), but was not exposed. we need it to do so to make wine happy...
* | math: more correct tgmath.h type cast logicSzabolcs Nagy2012-12-191-32/+17
| | | | | | | | | | | | | | __IS_FP is a portable integer constant expression now (uses that unsigned long long is larger than float) the result casting logic should work now on all compilers supporting typeof
* | math: new type cast logic in tgmath.hSzabolcs Nagy2012-12-191-25/+58
|/ | | | | | | | | | | | | | | | | | | | | | | | | | | * return type logic is simplified a bit and fixed (see below) * return type of conj and cproj were wrong on int arguments * added comments about the pending issues (usually we don't have comments in public headers but this is not the biggest issue with tgmath.h) casting the result to the right type cannot be done in c99 (c11 _Generic can solve this but that is not widely supported), so the typeof extension of gcc is used and that the ?: operator has special semantics when one of the operands is a null pointer constant the standard is very strict about the definition of null pointer constants so typeof with ?: is still not enough so compiler specific workaround is used for now on gcc '!1.0' is a null pointer constant so we can use the old __IS_FP logic (eventhough it's non-standard) on clang (and on gcc as well) 'sizeof(void)-1' is a null pointer constant so we can use !(sizeof(*(0?(int*)0:(void*)__IS_FP(x)))-1) (this is non-standard as well), the old logic is used by default and this new one on clang
* Merge remote-tracking branch 'nsz/math'Rich Felker2012-12-153-17/+9
|\
| * fixed tgmath.h for functions with integral resultSzabolcs Nagy2012-12-141-7/+9
| | | | | | | | | | | | | | in tgmath.h the return values are casted to the appropriate floating-point type (if the compiler supports gcc __typeof__), this is wrong in case of ilogb, lrint, llrint, lround, llround which do not need such cast
| * math: remove long double version of bessel functions from math.hSzabolcs Nagy2012-12-111-8/+0
| | | | | | | | | | | | | | j0l,j1l,jnl,y0l,j1l,jnl are gnu extensions, bsd and posix do not have them. noone seems to use them and there is no plan to implement them any time soon so we shouldn't declare them in math.h.
| * make CMPLX macros available in complex.h in non-c11 mode as wellSzabolcs Nagy2012-12-111-2/+0
| |
* | add some missing macros to sys/shm.hRich Felker2012-12-151-0/+3
| | | | | | | | | | these are not specified in the standard, but in the reserved namespace, so there is no problem with defining them unconditionally.
* | add missing flags in sys/timerfd.hRich Felker2012-12-131-0/+6
|/
* fix regressions in app compatibility from previous sys/ipc.h changesRich Felker2012-12-101-0/+5
| | | | | | | | | | | | despite glibc using __key and __seq rather than key and seq, some applications, notably busybox, assume the names are key and seq unless glibc is being used. and the names key and seq are really the ones that _should_ be exposed when not attempting to present a standards-conforming namespace; apps should not be using names that begin with double-underscore. thus, the optimal fix is to use key and seq as the actual names of the members when in bsd/gnu source profile, and define macros for __key and __seq that redirect to plain key and seq.
* syscall() declaration belongs in unistd.h, not sys/syscall.hRich Felker2012-12-102-10/+1
| | | | | | | traditionally, both BSD and GNU systems have it this way. sys/syscall.h is purely syscall number macros. presently glibc exposes the syscall declaration in unistd.h only with _GNU_SOURCE, but that does not reflect historical practice.
* fix names of ipc_perm __key/__seq elementsRich Felker2012-12-061-6/+2
| | | | | | | | | | | | | previously the names were exposed as key/seq with _GNU_SOURCE and __ipc_perm_key/__ipc_perm/seq otherwise, whereas glibc always uses __key and __seq for the names. thus, the old behavior never matched glibc, and the new behavior always does, regardless of feature test macros. for now, i'm leaving the renaming here in sys/ipc.h where it's easy to change globally for all archs, in case something turns out to be wrong, but eventually the names could just be incorporated directly into the bits headers for each arch and the renaming removed.
* fix F_DUPFD_CLOEXEC being defined twicerofl0r2012-12-061-1/+0
|
* fixup for fcntl.h changesrofl0r2012-12-061-16/+15
|
* add personality syscallrofl0r2012-12-061-0/+6
|
* add sigandset and sigorset (needed for qemu)rofl0r2012-12-061-0/+3
|
* add struct msgbuf to sys/msg.hrofl0r2012-12-061-0/+7
|
* unistd.h: fix wrong type for gid_t argumentrofl0r2012-12-061-1/+1
| | | | | the prototype is defined with const gid_t* rather than const gid_t[]. it was already correctly defined in grp.h.
* ipc.h: fix gnu aliases for key and seq in struct ipc_permrofl0r2012-12-061-2/+4
| | | | | the macro was the wrong way round, additionally GNU defines __ prefixed versions, which are used by qemu.
* add obsolete futimesat()rofl0r2012-12-061-0/+1
| | | | | | this function is obsolete, however it's available as a syscall and as such qemu userspace emulation tries to forward it to the host kernel.
* fcntl.h: add some linux-specific F_ macrosrofl0r2012-12-061-0/+17
| | | | | thankfully these are all generic across archs. the DN_ macros are for usage with F_NOTIFY.
* tcp.h: add SOL_TCP, analoguous to udp.hrofl0r2012-12-061-0/+2
|
* fix inefficiency of math.h isless, etc. macrosRich Felker2012-12-051-15/+30
| | | | | | | | | | | previously, everything was going through an intermediate conversion to long double, which caused the extern __fpclassifyl function to get invoked, preventing virtually all optimizations of these operations. with the new code, tests on constant float or double arguments compile to a constant 0 or 1, and tests on non-constant expressions are efficient. I may later add support for __builtin versions on compilers that support them.
* add scsi headers scsi.h and sg.hRich Felker2012-12-052-0/+279
| | | | | | | | due to some historical oddity, these are considered libc headers rather than kernel headers. the kernel used to provide them too, but it seems modern kernels do not install them, so let's just do the easiest thing and provide them. stripped-down versions provided by John Spencer.