about summary refs log tree commit diff
path: root/arch/powerpc
Commit message (Collapse)AuthorAgeFilesLines
* refactor to remove arch-specific relocation code from dynamic linkerRich Felker2014-06-181-24/+12
| | | | | | | | | | | this was one of the main instances of ugly code duplication: all archs use basically the same types of relocations, but roughly equivalent logic was duplicated for each arch to account for the different naming and numbering of relocation types and variation in whether REL or RELA records are used. as an added bonus, both REL and RELA are now supported on all archs, regardless of which is used by the standard toolchain.
* fix powerpc dynamic linker thread-pointer-relative relocationsRich Felker2014-06-171-3/+3
| | | | | | | processing of R_PPC_TPREL32 was ignoring the addend provided by the RELA-style relocation and instead using the inline value as the addend. this presumably broke dynamic-linked access to initial TLS in cases where the addend was nonzero.
* dynamic linker: permit error returns from arch-specific reloc functionRich Felker2014-06-161-1/+2
| | | | | | | | the immediate motivation is supporting TLSDESC relocations which require allocation and thus may fail (unless we pre-allocate), but this mechanism should also be used for throwing an error on unsupported or invalid relocation types, and perhaps in certain cases, for reporting when a relocation is not satisfiable.
* add sched_{get,set}attr syscall numbers and SCHED_DEADLINE macroSzabolcs Nagy2014-05-301-0/+4
| | | | | | | | | | | | linux 3.14 introduced sched_getattr and sched_setattr syscalls in commit d50dde5a10f305253cbc3855307f608f8a3c5f73 and the related SCHED_DEADLINE scheduling policy in commit aab03e05e8f7e26f51dee792beddcb5cca9215a5 but struct sched_attr "extended scheduling parameters data structure" is not yet exported to userspace (necessary for using the syscalls) so related uapi definitions are not added yet.
* make socketcall types common as they are same for all architecturesTimo Teräs2014-04-171-18/+0
|
* fix RLIMIT_ constants for mipsSzabolcs Nagy2014-04-151-0/+0
| | | | | | | The mips arch is special in that it uses different RLIMIT_ numbers than other archs, so allow bits/resource.h to override the default RLIMIT_ numbers (empty on all archs except mips). Reported by orc.
* fix signal.h breakage from moving stack_t to arch-specific bitsRich Felker2014-03-181-6/+6
| | | | | | in the previous changes, I missed the fact that both the prototype of the sigaltstack function and the definition of ucontext_t depend on stack_t.
* move signal.h definition of stack_t to arch-specific bitsRich Felker2014-03-181-0/+6
| | | | | it's different at least on mips. mips version will be fixed in a separate commit to show the change.
* fix socket.h struct msghdr member types on powerpcRich Felker2014-03-111-4/+4
| | | | | | these were incorrectly copied from the kernel, whose ABI matches the POSIX requirements but with the wrong underlying types and wrong signedness.
* fix sysvipc structures on powerpcRich Felker2014-03-114-20/+16
| | | | | | | | these have been wrong for a long time and were never detected or corrected. powerpc needs some gratuitous extra padding/reserved slots in ipc_perm, big-endian ordering for the padding of time_t slots that was intended by the kernel folks to allow a transition to 64-bit time_t, and some minor gratuitous reordering of struct members.
* move struct semid_ds to from shared sys/sem.h to bitsRich Felker2014-03-111-0/+16
| | | | | | | | | | | | the definition was found to be incorrect at least for powerpc, and fixing this cleanly requires making the definition arch-specific. this will allow cleaning up the definition for other archs to make it more specific, and reversing some of the ugliness (time_t hacks) introduced with the x32 port. this first commit simply copies the existing definition to each arch without any changes. this is intentional, to make it easier to review changes made on a per-arch basis.
* sys/shm.h: move arch specific structs to bits/rofl0r2014-02-231-0/+11
|
* fix namespace violations in termios.h, at least mostlyRich Felker2014-01-081-8/+10
| | | | | | the fix should be complete on archs that use the generic definitions (i386, arm, x86_64, microblaze), but mips and powerpc have not been checked thoroughly and may need more fixes.
* workaround clang deficiency affecting thread pointer access on powerpcRich Felker2013-12-021-1/+6
| | | | | based on patch by Richard Pennington, who initially reported the issue.
* add O_TMPFILE flag, new in linux 3.11Szabolcs Nagy2013-11-231-0/+1
| | | | | | definition in linux: #define O_TMPFILE (__O_TMPFILE | O_DIRECTORY) where __O_TMPFILE and O_DIRECTORY are arch specific
* fix the nominal type of LDBL_* limits on archs with ld64Rich Felker2013-11-201-4/+4
| | | | | | | | | | | previously these macros wrongly had type double rather than long double. I see no way an application could detect the error in C99, but C11's _Generic can trivially detect it. at the same time, even though these archs do not have excess precision, the number of decimal places used to represent these constants has been increased to 21 to be consistent with the decimal representations used for the DBL_* macros.
* support configurable page size on mips, powerpc and microblazeSzabolcs Nagy2013-09-152-2/+1
| | | | | | | | | | | | | | | | PAGE_SIZE was hardcoded to 4096, which is historically what most systems use, but on several archs it is a kernel config parameter, user space can only know it at execution time from the aux vector. PAGE_SIZE and PAGESIZE are not defined on archs where page size is a runtime parameter, applications should use sysconf(_SC_PAGE_SIZE) to query it. Internally libc code defines PAGE_SIZE to libc.page_size, which is set to aux[AT_PAGESZ] in __init_libc and early in __dynlink as well. (Note that libc.page_size can be accessed without GOT, ie. before relocations are done) Some fpathconf settings are hardcoded to 4096, these should be actually queried from the filesystem using statfs.
* add missing a_or_l to atomic.h for non-x86 archsRich Felker2013-08-111-0/+5
| | | | this is needed for recently committed sigaction code
* fix powerpc build breakage from dynamic linker path search changesRich Felker2013-07-261-1/+1
|
* new mostly-C crt1 implementationRich Felker2013-07-261-0/+12
| | | | | | | | | | | | | | | the only immediate effect of this commit is enabling PIE support on some archs that did not previously have any Scrt1.s, since the existing asm files for crt1 override this C code. so some of the crt_arch.h files committed are only there for the sake of documenting what their archs "would do" if they used the new C-based crt1. the expectation is that new archs should use this new system rather than using heavy asm for crt1. aside from being easier and less error-prone, it also ensures that PIE support is available immediately (since Scrt1.o is generated from the same C source, using -fPIC) rather than having to be added as an afterthought in the porting process.
* change jmp_buf to share an underlying type and struct tag with sigjmp_bufRich Felker2013-07-241-1/+1
| | | | | | | | | | this is necessary to meet the C++ ABI target. alternatives were considered to avoid the size increase for non-sig jmp_buf objects, but they seemed to have worse properties. moreover, the relative size increase is only extreme on x86[_64]; one way of interpreting this is that, if the size increase from this patch makes jmp_buf use too much memory, then the program was already using too much memory when built for non-x86 archs.
* remove SIG_ATOMIC_MIN/MAX from stdint bits headersRich Felker2013-07-221-2/+0
| | | | i386 was done with the big commit but I missed the others
* fix regression in size of nlink_t (broken stat struct) on x86_64Rich Felker2013-07-221-0/+1
| | | | | | | | rather than moving nlink_t back to the arch-specific file, I've added a macro _Reg defined to the canonical type for register-size values on the arch. this is not the same as _Addr for (not-yet-supported) 32-on-64 pseudo-archs like x32 and mips n32, so a new macro was needed.
* change wint_t to unsignedRich Felker2013-07-221-1/+1
| | | | | | | | | | | | aside from the obvious C++ ABI purpose for this change, it also brings musl into alignment with the compiler's idea of the definition of wint_t (use in -Wformat), and makes the situation less awkward on ARM, where wchar_t is unsigned. internal code using wint_t and WEOF was checked against this change, and while a few cases of storing WEOF into wchar_t were found, they all seem to operate properly with the natural conversion from unsigned to signed.
* refactor headers, especially alltypes.h, and improve C++ ABI compatRich Felker2013-07-223-133/+27
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | the arch-specific bits/alltypes.h.sh has been replaced with a generic alltypes.h.in and minimal arch-specific bits/alltypes.h.in. this commit is intended to have no functional changes except: - exposing additional symbols that POSIX allows but does not require - changing the C++ name mangling for some types - fixing the signedness of blksize_t on powerpc (POSIX requires signed) - fixing the limit macros for sig_atomic_t on x86_64 - making dev_t an unsigned type (ABI matching goal, and more logical) in addition, some types that were wrongly defined with long on 32-bit archs were changed to int, and vice versa; this change is non-functional except for the possibility of making pointer types mismatch, and only affects programs that were using them incorrectly, and only at build-time, not runtime. the following changes were made in the interest of moving non-arch-specific types out of the alltypes system and into the headers they're associated with, and also will tend to improve application compatibility: - netdb.h now includes netinet/in.h (for socklen_t and uint32_t) - netinet/in.h now includes sys/socket.h and inttypes.h - sys/resource.h now includes sys/time.h (for struct timeval) - sys/wait.h now includes signal.h (for siginfo_t) - langinfo.h now includes nl_types.h (for nl_item) for the types in stdint.h: - types which are of no interest to other headers were moved out of the alltypes system. - fast types for 8- and 64-bit are hard-coded (at least for now); only the 16- and 32-bit ones have reason to vary by arch. and the following types have been changed for C++ ABI purposes; - mbstate_t now has a struct tag, __mbstate_t - FILE's struct tag has been changed to _IO_FILE - DIR's struct tag has been changed to __dirstream - locale_t's struct tag has been changed to __locale_struct - pthread_t is defined as unsigned long in C++ mode only - fpos_t now has a struct tag, _G_fpos64_t - fsid_t's struct tag has been changed to __fsid_t - idtype_t has been made an enum type (also required by POSIX) - nl_catd has been changed from long to void * - siginfo_t's struct tag has been removed - sigset_t's has been given a struct tag, __sigset_t - stack_t has been given a struct tag, sigaltstack - suseconds_t has been changed to long on 32-bit archs - [u]intptr_t have been changed from long to int rank on 32-bit archs - dev_t has been made unsigned summary of tests that have been performed against these changes: - nsz's libc-test (diff -u before and after) - C++ ABI check symbol dump (diff -u before, after, glibc) - grepped for __NEED, made sure types needed are still in alltypes - built gcc 3.4.6
* change uid_t, gid_t, and id_t to unsigned typesRich Felker2013-07-191-3/+3
| | | | | | | | | this change is both to fix one of the remaining type (and thus C++ ABI) mismatches with glibc/LSB and to allow use of the full range of uid and gid values, if so desired. passwd/group access functions were not prepared to deal with unsigned values, so they too have been fixed with this commit.
* make the dynamic linker find its path file relative to its own locationRich Felker2013-07-181-1/+1
| | | | | | | | | | | | | | | | | | | prior to this change, using a non-default syslibdir was impractical on systems where the ordinary library paths contain musl-incompatible library files. the file containing search paths was always taken from /etc, which would either correspond to a system-wide musl installation, or fail to exist at all, resulting in searching of the default library path. the new search strategy is safe even for suid programs because the pathname used comes from the PT_INTERP header of the program being run, rather than any external input. as part of this change, I have also begun differentiating the names of arch variants that differ by endianness or floating point calling convention. the corresponding changes in the build system and and gcc wrapper script (to use an alternate dynamic linker name) for these configurations have not yet been made.
* respect iso c namespace in stdio.h and wchar.h regarding va_listRich Felker2013-06-251-0/+1
| | | | | | | | | | despite declaring functions that take arguments of type va_list, these headers are not permitted by the c standard to expose the definition of va_list, so an alias for the type must be used. the name __isoc_va_list was chosen to convey that the purpose of this alternate name is for iso c conformance, and to avoid the multitude of names which gcc mangles with its hideous "fixincludes" monstrosity, leading to serious header breakage if these "fixes" are run.
* Merge remote-tracking branch 'nsz/review'Rich Felker2013-05-261-22/+3
|\
| * fix ioctl _IOR, _IOW, etc macros to avoid signed overflow (2<<30)Szabolcs Nagy2013-05-261-22/+3
| |
* | change underlying type of clock_t to be uniform and match ABIRich Felker2013-05-231-1/+1
|/ | | | | | | | | | previously we were using an unsigned type on 32-bit systems so that subtraction would be well-defined when it wrapped, but since wrapping is non-conforming anyway (when clock() overflows, it has to return -1) the only use of unsigned would be to buy a little bit more time before overflow. this does not seem worth having the type vary per-arch (which leads to more arch-specific bugs) or disagree with the ABI musl (mostly) follows.
* add FLT_TRUE_MIN, etc. macros from C11Rich Felker2013-05-171-0/+1
| | | | | | | | there was some question as to how many decimal places to use, since one decimal place is always sufficient to identify the smallest denormal uniquely. for now, I'm following the example in the C standard which is consistent with the other min/max macros we already had in place.
* fix type issues in stdint.h so underlying types of 64-bit types match ABIRich Felker2013-04-041-0/+3
|
* eliminate bits/wchar.hRich Felker2013-04-041-4/+0
| | | | | | | the preprocessor can reliably determine the signedness of wchar_t. L'\0' is used for 0 in the expressions so that, if the underlying type of wchar_t is long rather than int, the promoted type of the expression will match the type of wchar_t.
* re-add useconds_trofl0r2013-04-021-0/+1
| | | | | | | | this type was removed back in 5243e5f1606a9c6fcf01414e , because it was removed from the XSI specs. however some apps use it. since it's in the POSIX reserved namespace, we can expose it unconditionally.
* add syscall numbers for the new kcmp and finit_module syscallsSzabolcs Nagy2013-04-011-1/+4
| | | | and remove syscall todos from microblaze
* add the new SO_REUSEPORT socket option to mips and powerpcSzabolcs Nagy2013-04-011-0/+1
| | | | | SO_REUSEPORT implementation was merged in the linux kernel commit c617f398edd4db2b8567a28e899a88f8f574798d 2013-01-23
* remove __SYSCALL_SSLEN arch macro in favor of using public _NSIGRich Felker2013-03-261-2/+0
| | | | | | | | | | | | | | the issue at hand is that many syscalls require as an argument the kernel-ABI size of sigset_t, intended to allow the kernel to switch to a larger sigset_t in the future. previously, each arch was defining this size in syscall_arch.h, which was redundant with the definition of _NSIG in bits/signal.h. as it's used in some not-quite-portable application code as well, _NSIG is much more likely to be recognized and understood immediately by someone reading the code, and it's also shorter and less cluttered. note that _NSIG is actually 65/129, not 64/128, but the division takes care of throwing away the off-by-one part.
* add deprecated SIGIOT alias for SIGABRTRich Felker2013-03-231-1/+1
| | | | reportedly some programs (e.g. showkeys in the kbd package) use it.
* fix types for wctype_t and wctrans_tRich Felker2013-03-041-2/+2
| | | | | | | | | | | | | | | | | | | | wctype_t was incorrectly "int" rather than "long" on x86_64. not only is this an ABI incompatibility; it's also a major design flaw if we ever wanted wctype_t to be implemented as a pointer, which would be necessary if locales support custom character classes, since int is too small to store a converted pointer. this commit fixes wctype_t to be unsigned long on all archs, matching the LSB ABI; this change does not matter for C code, but for C++ it affects mangling. the same issue applied to wctrans_t. glibc/LSB defines this type as const __int32_t *, but since no such definition is visible, I've just expanded the definition, int, everywhere. it would be nice if these types (which don't vary by arch) could be in wctype.h, but the OB XSI requirement in POSIX that wchar.h expose some types and functions from wctype.h precludes doing so. glibc works around this with some hideous hacks, but trying to duplicate that would go against the intent of musl's headers.
* add missing mmap options and madvices to bits/mman.h based on linux headersSzabolcs Nagy2013-01-121-0/+7
|
* add missing F_GETOWNER_UIDS flag to bits/fcntl.hSzabolcs Nagy2013-01-121-0/+1
|
* add missing EHWPOISON to bits/errno.hSzabolcs Nagy2013-01-121-0/+1
| | | | it was already defined for mips, but was missing from other archs
* fix trailing whitespace issues that crept in here and thereRich Felker2012-12-071-9/+9
|
* add more arch-specific MAP_ macros to bits/mman.hrofl0r2012-12-061-0/+4
| | | | these are also needed by qemu.
* remove MAP_32 from non-x86 archsrofl0r2012-12-061-1/+0
| | | | both kernel and glibc define it only on x86(_64).
* add MAP_NORESERVE to bits/mman.hrofl0r2012-12-061-0/+1
| | | | | this is needed for qemu, and since it differs for each arch it can't be circumvented easily by using a macro in CFLAGS.
* remove stat member aliases from ppc-specific bits/stat.hRich Felker2012-11-261-6/+0
| | | | | if these are to be supported, they belong in the main stat.h, not repeated for each arch.
* fixup mcontext stuff to expost gregset_t/fpregset_t as appropriateRich Felker2012-11-251-1/+1
|
* make sys/procfs.h mostly work on most archsRich Felker2012-11-251-0/+11
| | | | | | | | these structures are purely for use by trace/debug tools and tools working with core files. the definition of fpregset_t, which was previously here, has been removed because it was wrong; fpregset_t should be the type used in mcontext_t, not the type used in ptrace/core stuff.