summary refs log tree commit diff
path: root/kbfunc.c
Commit message (Collapse)AuthorAgeFilesLines
* cvsimportokan2018-02-061-49/+61
|\ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * refs/heads/master: (28 commits) Use screen's saved view instead of re-querying the server. Slightly expand and expose verbose debugging. add debugging for x events Add a simple debug logging mechanism. Simplification; use asprintf where appropriate now. Use func attributes where appropriate. Fix wins comparison declaration since it's unsigned from XQueryTree(). Generate name_to_func[] in a clean and readable fashion. Shrink tier[] by one after removing matchname in r1.55. If the requested group number is invalid, bail but don't kill cwm. Quick fix: exit after a failed execvp in u_spawn instead; previously we did in u_exec, but the introduction of re-exec'ing the previous invocation of cwm if 'exec_wm' failed missed the 'exec' failing path. Will likely split out as a proper fix. Only exec the fallback when in CWM_EXEC_WM state. Typo, from Julien Steinhauser. Convert menu-exec-wm from an abritrary exec menu, into a config-based menu from which one may configure (wm <name> <path_and_args>) (and choose) specific window managers to replace the running one. 'wm cwm cwm' is included by default. As done for buttonrelease, work specific un-cycling and un-highlighting actions into the keyrelease event, only performing what's actually needed for each; should result in much fewer events against keyreleases. No intended behaviour change. Merge group_toggle_membership_leave into the buttonrelease event and only do border work for a group/ungroup action. add helper function client_show to bring together like actions for unhide/raise Add support for re-exec'ing with SIGHUP; equivalent to the already built-in 'restart' function. Use poll and XNextEvent to replace XNextEvent blocking inside the x11 event handler. zap stray that snuck in ...
| * Convert menu-exec-wm from an abritrary exec menu, into a config-based menu fromokan2017-12-291-28/+30
| | | | | | | | | | | | | | | | which one may configure (wm <name> <path_and_args>) (and choose) specific window managers to replace the running one. 'wm cwm cwm' is included by default. No objections and seems sensible to sthen.
| * As done for buttonrelease, work specific un-cycling and un-highlighting actionsokan2017-12-291-2/+9
| | | | | | | | | | | | | | | | | | into the keyrelease event, only performing what's actually needed for each; should result in much fewer events against keyreleases. No intended behaviour change. Additionally, like we do for group membership, grab the keyboard only when required for cycling.
| * Merge group_toggle_membership_leave into the buttonrelease event and only dookan2017-12-291-1/+1
| | | | | | | | border work for a group/ungroup action.
| * add helper function client_show to bring together like actions for unhide/raiseokan2017-12-291-4/+1
| |
| * Use a variable to keep track of flags for menu_filter().okan2017-12-191-13/+21
| |
| * Unconditionally show prompt on menus, regardless of invocation.okan2017-12-111-5/+3
| |
* | cvsimportokan2017-12-071-8/+42
|\| | | | | | | | | | | | | | | | | * refs/heads/master: Original idea from Dimitris Papastamos to move windows to corners a while ago; re-proposed by Julien Steinhauser with an updated diff. Apparently this was in the original calmnwm. give command and group menus their own match callbacks stash dir into conf since it'll be of use organize this a bit better spacing
| * Original idea from Dimitris Papastamos to move windows to corners a while ago;okan2017-12-071-0/+36
| | | | | | | | | | | | | | | | | | re-proposed by Julien Steinhauser with an updated diff. Apparently this was in the original calmnwm. However, expand the original idea and let clients 'snap' to edges instead, neatly allowing key bindings that snap to adjacent edges (i.e. corners) as well. No default bindings assigned.
| * give command and group menus their own match callbacksokan2017-12-071-5/+4
| |
| * spacingokan2017-12-071-3/+2
| |
* | cvsimportokan2017-11-301-2/+2
|\| | | | | | | | | * refs/heads/master: Revert r1.109 (Switch to XWindowEvent() pulling out events that match the mask *and* window.) of mousefunc.c. When a client destroys itself while we are moving or resizing it, XWindowEvent() blocks. Found the hard way by Anton Lazarov, and Lea°hNeukirchen found the right bit to revert - thanks! Reverting since the reason to switch from XMaskEvent was unclear.
| * Revert r1.109 (Switch to XWindowEvent() pulling out events that match the maskokan2017-11-301-2/+2
| | | | | | | | | | | | | | *and* window.) of mousefunc.c. When a client destroys itself while we are moving or resizing it, XWindowEvent() blocks. Found the hard way by Anton Lazarov, and Lea°hNeukirchen found the right bit to revert - thanks! Reverting since the reason to switch from XMaskEvent was unclear.
* | cvsimportLeah Neukirchen2017-07-271-3/+140
|\| | | | | | | | | | | | | | | * refs/heads/master: Use the key names from keysymdef.h in the default key bindings list for clarification. remove extra parentheses Pull over the remaining re-implemented window move/resize functions and create a wrapper so that the key and mouse based move/resize callbacks can be unified. This has already been done with other window operations and menus. rename one function, matching others, to help upcoming change
| * remove extra parenthesesokan2017-07-141-2/+2
| |
| * Pull over the remaining re-implemented window move/resize functions and createokan2017-07-141-2/+139
| | | | | | | | | | a wrapper so that the key and mouse based move/resize callbacks can be unified. This has already been done with other window operations and menus.
| * rename one function, matching others, to help upcoming changeokan2017-07-121-1/+1
| |
* | drop fgetln.cLeah Neukirchen2017-07-111-0/+3
| |
* | cvsimportLeah Neukirchen2017-07-111-11/+10
|\| | | | | | | | | | | | | * refs/heads/master: Replace fgetln(3) with POSIX getline(3); inspired by brynet and Ingo. fix a few WARNINGS (new sentence, new line and extraneous Pp macro) found with mandoc -Tlint from src, by espie@: no need to generate y.tab.h if nothing uses it, set YFLAGS to nothing
| * Replace fgetln(3) with POSIX getline(3); inspired by brynet and Ingo.okan2017-07-101-11/+10
| | | | | | | | feedback and ok brynet@
* | cvsimportokan2017-05-091-93/+70
|\| | | | | | | | | | | | | | | | | * refs/heads/master: drop obsolete comment Alter callbacks to take a struct instead of a growing number of arguments; greatly simplifies upcoming work. Ensure clients stay within the viewable bounds on placement, even with empty borders; based on a patch from Vadim Vygonets. Clean up, unify and accurately calculate edge distance with client move/resize actions, so as to not lose windows off the edge. Switch bwidth type; unfortunately X11 is inconsistent.
| * Alter callbacks to take a struct instead of a growing number of arguments;okan2017-05-091-50/+49
| | | | | | | | greatly simplifies upcoming work.
| * Clean up, unify and accurately calculate edge distance with client move/resizeokan2017-05-011-43/+21
| | | | | | | | | | | | actions, so as to not lose windows off the edge. inspired by diffs (and feedback) from Vadim Vygonets.
* | cvsimportokan2017-01-051-0/+4
|\| | | | | | | | | | | * refs/heads/master: Ensure client stays inbound on key-based resize; based on logic existing in key-based client move; from Vadim Vygonets. When a window has a user or program specified position, ensure the edge of the final position is at least viewable and warp'able by the difference of bwidth; prevents mapping windows completely off the virtual screen.
| * Ensure client stays inbound on key-based resize; based on logic existing inokan2017-01-051-0/+4
| | | | | | | | key-based client move; from Vadim Vygonets.
* | fix buildChristian Neukirchen2016-12-161-1/+0
| |
* | cvsimportChristian Neukirchen2016-12-161-9/+12
|\| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * refs/heads/master: stray newlines Add search_print_text(), a default callback for mi->print in menu_filter(). While here, normalize the remaining search_print_* argument paramters. Consistent use of menuq_add for ssh menu. Now that dim.{x,y} are available early, use them before requiring a MotionNotify event. Set dim.{x,y} during client_init and update on resize, instead of (re)calculating only when applying hints. 'window-search' is spelled 'menu-window'; the former snuck in during the conversion('menu-window' already existed and was properlly documented); found the hard way by sthen@ while trying to convert. Fold unbinding functions into one for each, key and mouse; plugs a leak when unbinding a mouse button bound to a command. use the correct type Tame the number of 'exec' and 'path' search_match wrappers. No functional change now, though more can likely go later, losing the (paritally complete or incomplete/broken) argument completion bits. Switch ssh menu to search_match_text; like group/window/cmd menus, use only a substring match. The previous matching is only intended for the exec menus. Change 'menu-window' to display all windows; then add 'menu-window-hidden' for the previous behaviour of 'menu-window'. 'menu-window' becomes the default binding; use 'bind-mouse "1" menu-window-hidden' to restore old behaviour for those who prefer. Normalize bind function names, based on a few categories: window, group, menu and pointer. Use an additional check with lstat(2) when d_type is unknown. revert previous; upcoming changes will hopefully deal with these more naturally. Add a wrapper based upon xevent handlers around client move/resize for key and mouse bindings. Define callbacks, then default bindings. Reorganize for upcoming changes. Remove the (8) default bindings for pointer move since they conflict with default bindings for emacs, which wins; the feature remains and can be bound to whatever users wish with cwmrc(5).
| * Add search_print_text(), a default callback for mi->print in menu_filter(). ↵okan2016-12-061-3/+3
| | | | | | | | | | | | While here, normalize the remaining search_print_* argument paramters.
| * Consistent use of menuq_add for ssh menu.okan2016-12-061-1/+1
| |
| * Tame the number of 'exec' and 'path' search_match wrappers. No functionalokan2016-12-011-1/+1
| | | | | | | | | | change now, though more can likely go later, losing the (paritally complete or incomplete/broken) argument completion bits.
| * Switch ssh menu to search_match_text; like group/window/cmd menus, use only aokan2016-12-011-1/+1
| | | | | | | | substring match. The previous matching is only intended for the exec menus.
| * Change 'menu-window' to display all windows; then add 'menu-window-hidden' forokan2016-12-011-1/+2
| | | | | | | | | | | | | | | | the previous behaviour of 'menu-window'. 'menu-window' becomes the default binding; use 'bind-mouse "1" menu-window-hidden' to restore old behaviour for those who prefer. OK sthen@ (long long time ago on a different version)
| * Use an additional check with lstat(2) when d_type is unknown.okan2016-11-151-3/+10
| | | | | | | | from James McDonald via portable.
| * revert previous; upcoming changes will hopefully deal with these moreokan2016-11-151-22/+0
| | | | | | | | naturally.
| * Add a wrapper based upon xevent handlers around client move/resize for key andokan2016-11-151-0/+22
| | | | | | | | mouse bindings.
* | cvsimportokan2016-10-241-176/+209
|\| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * refs/heads/master: (34 commits) Make it clear these are flags. Remove duplicate check that strsubmatch() already does; while here, fix a comment. Sprinkle __func__ in appropriate error messages. Get rid of 'matchname'; it's too surprising to have the menu change during client search as different potential str matches are cycled through. If there's interest, the only string that doesn't exist in the listing is the window's class - that can be added of course, but it makes the line too long imho. clean up search_match_client(); no behaviour change Refactor callbacks to take a void * so as to not try and generalize into client_ctx in keypress and buttonpress event handlers; pass appropriate *ctx's based on context. remove another unused proto Rename 2 kbfunc to match closer to what they do Add an argument to the callbacks to pass the xevent context, button or key press. This allows to remove a few hacks to duplicate functions only for behaviour changes; now differing behaviours are pushed down to the callback. Also will allow for previously unavailable actions to be bind-able down the road. Check the ptr bounds in the new client during cycling, since not all actions do ptrsave, such as restoring client geometry; adapted from a diff by Vadim Vygonets. More accurate to say 'toggle', rather than 'select', for group[n]/nogroup. Add CM-a for 'nogroup' (CM-0 stays for now); update manpage to reflect. Stash wmname into conf. When removing xrandr regions, ensure clients are within the bounds of the screen; adapted from an ancient diff from Sviatoslav Chagaev. Things in this area will likely change, but put this in so it works now and serves as a reminder. Calculate client nameqlen in client_setname(), the only place it's needed/used. Turn CALMWM_NGROUPS define into variable, ngroups. Start simplifying menu code; and in turn, remove a cursor no longer needed. Defaults are split between defines and conf_init(); normalize these, as well as give 'sticky' groups its own variable. For both kb and mouse move, it is possible to grab a client and move it completely off the screen/region; instead, if the pointer is outside of the client bounds, warp the pointer to the closest edge before moving. client_ptrwarp should not deal with unhiding or raising clients (non ptr requests); most callers do this already - deal with the few that do not. client_ptrwarp becomes a simple wrapper (setpos) but it will be expanded. ...
| * Make it clear these are flags.okan2016-10-241-6/+6
| |
| * Sprinkle __func__ in appropriate error messages.okan2016-10-241-3/+3
| |
| * Refactor callbacks to take a void * so as to not try and generalize intookan2016-10-181-166/+170
| | | | | | | | | | | | | | | | client_ctx in keypress and buttonpress event handlers; pass appropriate *ctx's based on context. While here, limit some globals, replace defines with appropriate variables and fix some naming.
| * Rename 2 kbfunc to match closer to what they dookan2016-10-061-2/+2
| |
| * Add an argument to the callbacks to pass the xevent context, button orokan2016-10-061-35/+35
| | | | | | | | | | | | | | key press. This allows to remove a few hacks to duplicate functions only for behaviour changes; now differing behaviours are pushed down to the callback. Also will allow for previously unavailable actions to be bind-able down the road.
| * For both kb and mouse move, it is possible to grab a client and move itokan2016-10-031-1/+13
| | | | | | | | | | completely off the screen/region; instead, if the pointer is outside of the client bounds, warp the pointer to the closest edge before moving.
| * client_ptrwarp should not deal with unhiding or raising clients (non ptrokan2016-10-031-0/+2
| | | | | | | | | | requests); most callers do this already - deal with the few that do not. client_ptrwarp becomes a simple wrapper (setpos) but it will be expanded.
| * Continue merging kb and mouse functions: foldokan2016-09-221-7/+22
| | | | | | | | | | | | mousefunc_menu_{client,cmd,group} into the respective kbfunc_menu_{client,cmd,group} functions; simply pass a flag down from config denoting mouse action behaviour.
* | cvsimportokan2015-11-171-7/+9
|\| | | | | | | | | | | | | * refs/heads/master: Fix a typo from r1.201; fixes window_grouptoggle binding. If a client does not set increment values, use 'moveamount' as a way to scale keyboard based resizes; extend kbfunc_amount(). Inline the only use of mousefunc_sweep_calc.
| * If a client does not set increment values, use 'moveamount' as a way tookan2015-11-171-7/+9
| | | | | | | | | | | | scale keyboard based resizes; extend kbfunc_amount(). Behaviour noted by, tested by, and ok sthen@
* | cvsimportokan2015-11-121-96/+113
|\| | | | | | | | | | | | | | | | | | | | | | | | | * refs/heads/master: more client vs screen context differences If a client sets hints, honor them for kb resize requests, just like we do for mouse based resize requests. Move kb pointer movement out of the kbfunc_client_moveresize since it's got nothing to do with clients, thus doing flags work causes lots of waste and almost useless jumpy pointer movements; while here, split out move and resize since they share almost no code, just like mouse client move/resize; factor out amount and factor. Still wonder why this is here, but it works now. pledge "stdio rpath proc exec" cwm before main event loop, after init/setup - mostly for menu building. Partial revert of replacing screen_area() with region_find(); until a fix for a regression is found; this bug has been around for a long time it seems, but this change exposed it. Likely need to track clients in to and out of regions. Use position on root to figure out region. Start cleaning up name vs function differences; replace magic numbers. Clean up unused defines. Extend region to include both view and work areas; switch to region_find() which no longer needs to recalculate gap each time a client (or menu) is created or altered. If no RandR, fall back to display dimensions while building regions instead of during execution.
| * more client vs screen context differencesokan2015-11-121-4/+4
| |
| * If a client sets hints, honor them for kb resize requests, just like weokan2015-11-121-4/+4
| | | | | | | | | | | | do for mouse based resize requests. Based on a patch from Vadim Vygonets.
| * Move kb pointer movement out of the kbfunc_client_moveresize since it'sokan2015-11-121-75/+92
| | | | | | | | | | | | | | | | got nothing to do with clients, thus doing flags work causes lots of waste and almost useless jumpy pointer movements; while here, split out move and resize since they share almost no code, just like mouse client move/resize; factor out amount and factor. Still wonder why this is here, but it works now.