| Commit message (Collapse) | Author | Age | Files | Lines |
|\
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master:
cycling fix: when no client is active, warp pointer to last active; from Walter Alejandro Iglesias.
whitespace
Fix spelling of some unused MWM hints; from Sean C. Farley.
Add group-last command that shows only the previously active group; ok okan
Allow bare numbers for key and mouse bindings; taken from similar support in other parse.y's; from Leon Fischer <lfischer@airmail.cc>.
sync parse.y changes from base; ok naddy@
Do not attempt to grab keys without a keycode; this incidentally allows XF86 keys support.
|
| | |
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master:
Fixed memory leak in xu_get_strprop.
Prevent out of boundary write with configuration files in which too many quoted arguments are stored for other window managers.
Allow configuring a percentage window size of the master window during htile/vtile actions. From Uwe Werler, with a few manpage tweaks.
zap stray tabs
Instead of using _NET_ACTIVE_WINDOW on restart, use the pointer location to determine what client to set active. Reduces a round trip for every window.
Add support for SIGINT/SIGTERM.
Simplify conditional construct.
Trim event_mask to those that the root window actually needs.
No need to lookup current client early; move to right before it is needed.
Recommit 1.259, but now with TAILQ_FOREACH_SAFE.
Revert previous. Causes a crash as reported by Tom Murphy.
Simplify list markup.
Plug two memory leaks. Also get rid of a variable that is no longer necessary.
Remove ColormaskChange from event-mask since there's no event handler.
Unrelated style fixes, consistency changes and sorting, appropriate dosage/removal of wrappers, simplification of name queue, client cycle joins other kb/mb bound functions.
|
| |
| |
| |
| |
| | |
dosage/removal of wrappers, simplification of name queue, client cycle joins
other kb/mb bound functions.
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master: (23 commits)
Check the atom type on propertynotify before iterating.
use screen_find() for xrandr crtc changes
Find the managed screen from the parent window for client_current().
Print window id in hex; while here, remove unnecessary newline.
Similar to keypress event, fetch the screen from the event root window in the buttonpress handler; bail if we don't manage the screen. Allows us to find the current client based on the screen/event root.
extend verbose logging for key/button events
[keypress event] turns out we've been checking the wrong window for a matching client thus always falling back to client_current(); while the current client is problaby right in most cases, use event's subwindow (not window) to find the client. Bail early if this event came to us from a screen we don't manage. This is result of us grabing all keybindings off the root window instead of selectively.
add parans for readibility
Teach client_current() to use a screen to find the current client instead of iterating over all (fallback if no screen provided for now). Initially convert trivial uses of client_current().
check cc->gc directly
zip extra lines
gc clientq inside groups, instead use the better maintained one per-screen
shuffle deck chairs: rename group actions to match intent for clarity
same thing as screen_find()
Separate out the menu window from the client resize/move geom window; in each case, create and destroy on-demand. Isolate more menu specific code.
fix a few misplaced (and misnamed) ewmh root window functions
_NET_WORKAREA needs ngroups, so screen_update_geometry() needs to come after conf_group().
simplify xftcolor config
Tie group number and name together during config.
Move the group index (desktop number) check to the only 2 callers that require checking due to ewmh.
...
|
| | |
|
| | |
|
| | |
|
| | |
|
| |
| |
| |
| | |
checking due to ewmh.
|
| | |
|
| |
| |
| |
| | |
client_show().
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master:
Add 'group-close-[n]' action to close all windows within specified group.
simplify screen 'area' usage for initial client placement
restore order from before r1.248 (vtile/vtile containment changes).
Rename internal functions to delinate between client remove, delete and xproto delete; 'window-close' is now the proper action, but 'window-delete' as an alias will remain until more interesting changes require breaking configs.
Limit vtile/htile actions to clients fully within the screen of master client.
fix missing includes
|
| |
| |
| |
| | |
heavily based on a diff from Nam Nguyen.
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master: (28 commits)
Use screen's saved view instead of re-querying the server.
Slightly expand and expose verbose debugging.
add debugging for x events
Add a simple debug logging mechanism.
Simplification; use asprintf where appropriate now.
Use func attributes where appropriate.
Fix wins comparison declaration since it's unsigned from XQueryTree().
Generate name_to_func[] in a clean and readable fashion.
Shrink tier[] by one after removing matchname in r1.55.
If the requested group number is invalid, bail but don't kill cwm.
Quick fix: exit after a failed execvp in u_spawn instead; previously we did in u_exec, but the introduction of re-exec'ing the previous invocation of cwm if 'exec_wm' failed missed the 'exec' failing path. Will likely split out as a proper fix.
Only exec the fallback when in CWM_EXEC_WM state.
Typo, from Julien Steinhauser.
Convert menu-exec-wm from an abritrary exec menu, into a config-based menu from which one may configure (wm <name> <path_and_args>) (and choose) specific window managers to replace the running one. 'wm cwm cwm' is included by default.
As done for buttonrelease, work specific un-cycling and un-highlighting actions into the keyrelease event, only performing what's actually needed for each; should result in much fewer events against keyreleases. No intended behaviour change.
Merge group_toggle_membership_leave into the buttonrelease event and only do border work for a group/ungroup action.
add helper function client_show to bring together like actions for unhide/raise
Add support for re-exec'ing with SIGHUP; equivalent to the already built-in 'restart' function.
Use poll and XNextEvent to replace XNextEvent blocking inside the x11 event handler.
zap stray that snuck in
...
|
| | |
|
| |
| |
| |
| | |
border work for a group/ungroup action.
|
|\|
| |
| |
| |
| |
| | |
* refs/heads/master:
Fix group hidden state when a client wants to be on all desktops on start; reported by Vadim Vygonets with diff, but another approach was taken.
Call client_resize instead of client_move after client_placecalc since the size may also change.
|
| |
| |
| |
| | |
reported by Vadim Vygonets with diff, but another approach was taken.
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master: (34 commits)
Make it clear these are flags.
Remove duplicate check that strsubmatch() already does; while here, fix a comment.
Sprinkle __func__ in appropriate error messages.
Get rid of 'matchname'; it's too surprising to have the menu change during client search as different potential str matches are cycled through. If there's interest, the only string that doesn't exist in the listing is the window's class - that can be added of course, but it makes the line too long imho.
clean up search_match_client(); no behaviour change
Refactor callbacks to take a void * so as to not try and generalize into client_ctx in keypress and buttonpress event handlers; pass appropriate *ctx's based on context.
remove another unused proto
Rename 2 kbfunc to match closer to what they do
Add an argument to the callbacks to pass the xevent context, button or key press. This allows to remove a few hacks to duplicate functions only for behaviour changes; now differing behaviours are pushed down to the callback. Also will allow for previously unavailable actions to be bind-able down the road.
Check the ptr bounds in the new client during cycling, since not all actions do ptrsave, such as restoring client geometry; adapted from a diff by Vadim Vygonets.
More accurate to say 'toggle', rather than 'select', for group[n]/nogroup.
Add CM-a for 'nogroup' (CM-0 stays for now); update manpage to reflect.
Stash wmname into conf.
When removing xrandr regions, ensure clients are within the bounds of the screen; adapted from an ancient diff from Sviatoslav Chagaev. Things in this area will likely change, but put this in so it works now and serves as a reminder.
Calculate client nameqlen in client_setname(), the only place it's needed/used.
Turn CALMWM_NGROUPS define into variable, ngroups.
Start simplifying menu code; and in turn, remove a cursor no longer needed.
Defaults are split between defines and conf_init(); normalize these, as well as give 'sticky' groups its own variable.
For both kb and mouse move, it is possible to grab a client and move it completely off the screen/region; instead, if the pointer is outside of the client bounds, warp the pointer to the closest edge before moving.
client_ptrwarp should not deal with unhiding or raising clients (non ptr requests); most callers do this already - deal with the few that do not. client_ptrwarp becomes a simple wrapper (setpos) but it will be expanded.
...
|
| | |
|
| |
| |
| |
| |
| |
| |
| |
| | |
client_ctx in keypress and buttonpress event handlers; pass appropriate *ctx's
based on context.
While here, limit some globals, replace defines with appropriate variables and
fix some naming.
|
| | |
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master:
Some clients fail to setup hints at all, so initalize for them; fallout from r1.218 switching to malloc - clearly missed this case.
Fix-up a few simple uses of client_current(): check CLIENT_ACTIVE flag instead of relying on curcc.
init label
Limit mouse resize to hints within the client; matches kbd resize behaviour.
Switch to just malloc since we need initialize most everything anyway.
change 'sticky' to 'stick' to toggle client stickiness (seems the default binding worked for everyone for a long time!); conflict with group sticky found by Ali Farzanrad - thanks!
Simplify group_holds_only_hidden(); from Vadim Vygonets.
Simplify toggling flags; from Vadim Vygonets.
Do not draw borders on ignored clients when returning from fullscreen; from Vadim Vygonets.
Remove redundant minimum client size adjustment (minw and minh are always positive since r1.214); from Vadim Vygonets.
|
| | |
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master:
more client vs screen context differences
If a client sets hints, honor them for kb resize requests, just like we do for mouse based resize requests.
Move kb pointer movement out of the kbfunc_client_moveresize since it's got nothing to do with clients, thus doing flags work causes lots of waste and almost useless jumpy pointer movements; while here, split out move and resize since they share almost no code, just like mouse client move/resize; factor out amount and factor. Still wonder why this is here, but it works now.
pledge "stdio rpath proc exec" cwm before main event loop, after init/setup - mostly for menu building.
Partial revert of replacing screen_area() with region_find(); until a fix for a regression is found; this bug has been around for a long time it seems, but this change exposed it. Likely need to track clients in to and out of regions.
Use position on root to figure out region.
Start cleaning up name vs function differences; replace magic numbers.
Clean up unused defines.
Extend region to include both view and work areas; switch to region_find() which no longer needs to recalculate gap each time a client (or menu) is created or altered. If no RandR, fall back to display dimensions while building regions instead of during execution.
|
| | |
|
|\|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* refs/heads/master: (21 commits)
Lost fix from r1.112; add comment.
Mechanical change: group->gc
Add consistent checks against NULL.
Move client cycle grab/ungrab into a more relevant place; while here, update comments about why we need to grab/ungrab the keyboard.
Re-add lost chunk in group_cycle from r1.113.
Further simplify _NET_WM_DESKTOP handling using new group_assign().
oops; remove left over debug print
Allowing sending a valid 'nogroup' (0) group_ctx to group_assign() (since we init all groups), though assigning the client's group to NULL for 'sticky'; use this simplification in a few places (others to follow).
Split out sticky mode checks and the restoring of a client's group and _NET_WM_DESKTOP from the config-based auto-grouping; no (intentional) behavior changes. Needed for further work in cleaning up this area.
Implement _NET_CLIENT_LIST_STACKING (from Thomas Admin), but bottom-to-top order, as per spec (notified Thomas as well).
Don't allow freeze operations on fullscreen (consistent with what fullscreen does).
Sort _NET_WM_STATE Atoms like the spec.
Move CLIENT_STICKY logic from client hide/unhide to group hide/unhide; rationale being that clients should be able to hide/unhide independently of group switching.
Add Xkb modifier to ignore mask; from Alexander Polakov.
Fix whitespace.
Add client freeze extension to _NET_WM_STATE Atom, allowing flag to persist. As usual with new Atoms, requires X restart.
_NET_WM_STATE_STICKY implies only sticky at the group/desktop level, not position and size; based on discussion with a few.
Instead of special casing the 'term' and 'lock' commands, go back to keeping them hidden; showing them has apparently caused confusion/angst.
Leave command list order from .cwmrc alone; remove sort.
Bring group and client cycle closer together.
...
|
| | |
|
| | |
|
| | |
|
| | |
|
| |
| |
| |
| |
| |
| | |
(since we init all groups), though assigning the client's group to NULL
for 'sticky'; use this simplification in a few places (others to
follow).
|
| |
| |
| |
| |
| | |
_NET_WM_DESKTOP from the config-based auto-grouping; no (intentional)
behavior changes. Needed for further work in cleaning up this area.
|
| |
| |
| |
| |
| | |
rationale being that clients should be able to hide/unhide independently
of group switching.
|
| | |
|
|\| |
|
| | |
|
|\| |
|
| |
| |
| |
| | |
not require zero'ing.
|
|\| |
|
| |
| |
| |
| |
| |
| | |
and HOST_NAME_MAX+1, respectively.
ok doug@
|
|\| |
|
| | |
|
|\| |
|
| | |
|
| |
| |
| |
| | |
index which then needed to be found in a queue.
|
| | |
|
| |
| |
| |
| | |
initialize hideall and cycling.
|
|\| |
|