summary refs log tree commit diff
path: root/group.c
Commit message (Collapse)AuthorAgeFilesLines
* spacing nitsokan2010-09-251-4/+5
|
* revert -r1.45 of group.c (log was: fix window name and class to matchokan2010-07-301-2/+3
| | | | | | | | | | | | cwmrc(5)). instead, fix cwmrc(5) to match the old behavior which also happens to match the example config, of which many have based their configs; this also nicely matches the output of xprop(1). clean-up of variable names as a separate commit. suggested by sthen (and something we should have done initially). discussed with and ok oga@
* fix window name and class to match cwmrc(5); from Holger Mikolon - thanks!okan2010-06-281-3/+2
| | | | ok oga@
* clean up a few xu_* functions to just accept what they need (Window).okan2010-04-111-1/+1
| | | | ok oga@
* pull all non-X11 headers from calmwm.h and place them only where theyokan2009-12-151-0/+9
| | | | | | are required. encourged to go all the way by oga@
* spacingokan2009-12-151-3/+1
|
* pull these headers only into files that need them.okan2009-12-151-0/+2
| | | | ok oga@
* merge the 2 common header files; specific includes to be pulled out asokan2009-12-151-1/+0
| | | | | | separate commits. ok oga@
* kill _CWM_GRP atom setting. The netwm stuff does us well enough now thatoga2009-12-141-16/+1
| | | | | | it's superfluous. ok okan@
* implement support for _NET_WM_DESKTOP properties on windows.oga2009-12-111-6/+25
| | | | | | | | | | | | it works kinda like _CWM_GRP, which we added to aid restarts a while ago, but it's standardised and clients are specifically allowed to set it to request a desktop. for noe we leave _CWM_GRP support in, but its days are now numbered. while i'm here fixup an int/long mixup with an earlier diff. ok okan@
* Implement _NET_DESKTOP_NAMES, this one was a bit tricky since thespecoga2009-12-111-9/+116
| | | | | | | | | | says that a pager can change the property at any time (most need a clientmessage). So deal with property updates. Needed to shuffle some of the other code around since we can't just use shortcut_to_name[] everywhere now. ok okan@
* Implement _NET_VIRTUAL_ROOTS (just clear it, we don't use that technique)oga2009-12-101-1/+14
| | | | | | | | and _NET_SHOWING_DESKTOP (we're never doing so right now). only three informational root-window hints to go. ok okan@
* Implement _NET_CURRENT_DESKTOP, _NET_DESKTOP_VIEWPORT andoga2009-12-101-7/+20
| | | | | | _NET_DESKTOP_GEOMETRY. ok okan@
* finish unfucking the screen_ctx handling.oga2009-12-101-50/+54
| | | | | | | | | | | | | remove screen_current() it was utterly bogus when nscreens > 1. pass a fake client_ctx in the case where there's no client and the kbfunc or mousefunc doesn't need a real one, it just contains the current screen, modify these functions so that they pass down the screen context to their callees. make groups per screen, it's the only way it makes sense in this regard. ok okan@.
* Implement _NET_NUMBER_OF_DESKTOPS, currently this is statically 9 andoga2009-12-071-2/+0
| | | | | | | unchangable. the group code needs some cleaning up before this will be a bit less hackish. ok okan@
* compact a bit by condensing a few if-else's; from Thomas Pfaffokan2009-06-201-8/+2
| | | | "go on then" oga@
* unroll XCALLOC/XMALLOC macros; since we use xcalloc/xmalloc all over theokan2009-06-201-1/+1
| | | | | | place anyway, this makes things a bit more consistent; from Thomas Pfaff ok oga@
* In movetogroup, check the window's current group and skip client_hide()sthen2009-05-191-1/+2
| | | | | if it's the same as the active group. Was in my original movetogroup diff, but it got simplified a little too far. ok oga@
* nuke the leading underscore notation for local static functions - thereokan2009-05-181-29/+29
| | | | | | are far better ways to know. "go for it" oga@
* a long time coming - re-work the way we deal with colors: since we'reokan2009-05-171-2/+2
| | | | | | | | using Xft(3), use it to select the font color as well instead of trying to build one; properly allocate and free colors at-will, e.g. we now have configurable colors. feedback and ok's todd@ and oga@
* minor bit of knf, just to be consistent; oga@ doesn't mind that muchokan2009-05-171-3/+2
|
* unbreakokan2009-05-171-0/+1
|
* add a "movetogroup" function, which hides the current window fromsthen2009-05-171-1/+10
| | | | | | | | | | | | display and moves it to another group. useful with the recently added "grouponly" function, giving the ability to use groups as simple virtual desktops (similar to e.g. xmonad, dwm and scrotwm). this doesn't have default keyboard bindings; cwmrc(5) now shows how you could use these functions (use M-1...9 for grouponly1...9 and MS-1...9 for movetogroup1...9 to emulate the default dwm bindings). ok oga@
* Add a new command (currently no default keybindings for it), grouponly[1-9].oga2009-05-141-0/+17
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This works like the group select binding, but hides all other groups. So, the people who've been complaining that they don't get "virtual desktops" in cwm may want to try this out in cwmrc (from memory, untested): --- #cwmrc # add new windows to the current group set sticky # automatically sticky windows. xclock for now. # to make more windows sticky use group_toggle to unset their group autogroup 0 xclock # make the group selection keys hide other groups, emulate virtual desktops bind CM-1 grouponly1 bind CM-2 grouponly2 bind CM-3 grouponly3 bind CM-4 grouponly4 bind CM-5 grouponly5 bind CM-6 grouponly6 bind CM-7 grouponly7 bind CM-8 grouponly8 bind CM-9 grouponly9 --- mostly by sthen, tweaks from me. ok todd@, "if it works i'm ok with it" okan@, ok sthen@
* One of the most annoying things to do was restart cwm and lose all ofoga2009-01-271-6/+21
| | | | | | | | | | your group state. Fix this up by using an X Atom (_CWM_GRP) to store the name of the group that we're using (the name, not the number is because at one point we may make the group numbers dynamic). I've been talking about this since c2k8. so CM-w means you keep all of your windows grouped properly. ok okan@, todd@
* remove pwin, bringing us to one client, one window. we no longer haveokan2009-01-161-1/+1
| | | | | | | | | | | | to push attributes around, so things get a lot simplier, while fixing a few issues in the meantime; original suggestion by Edd Barrett many many moons ago. annoying window placement and race, found in c2k8 by todd, fix by oga! lots of feedback from todd and oga - thanks! "commit that bad boy" oga@
* - add missing prototypes.okan2009-01-151-7/+10
| | | | | | | | | - properly name, place and static private functions. - move function which finds the xinerama screen for a coordinate to a more appropriate place while altering its semantics to match others. - tiny bit of style. ok oga@
* shortcut_to_name should not be defined as static in a header file. Putoga2009-01-111-0/+5
| | | | | | | it in group.c where it it used most, and add an extern definition for the other users of it. Found by gcc -Wall. ok okan@
* Put back the initialisation of gc in group_cycle. No cookie for okan.oga2008-07-181-0/+1
| | | | Reported by Dan Harnett, thanks!
* spacing, declaration lineup to be consistent throughout cwm,okan2008-07-111-18/+19
| | | | | | readability, and a bit of knf. ok oga@
* Make menu_filter handle mouse movement too. This enables the keyboardoga2008-05-211-1/+1
| | | | | | | | | | search dialogues to be manipulated with the mouse, too. It also allows me to shrink the codebase further by killing grab_menu(). One known issue with highlighting the first entry in a search dialogue, that'll be fixed soonish. ok okan@, tested by Edd Barrett and todd@.
* allow an autogroup value of 0 to mean no group. This means you can setoga2008-05-191-0/+3
| | | | | | | | | automatically "sticky" (in the traditional sense of the word) windows in autogroup mode. Based on an initial diff from Andrew Fresh, thanks! ok okan@.
* as done with cycle/rcycle, make prev/next group switching one kbfuncsokan2008-05-191-9/+6
| | | | | | and use a flag; adjusted to match and rename to {r,}cycle. "ok, since i came up with the same thing" oga@
* remove extra calls to client_draw_border()okan2008-05-181-2/+0
| | | | ok oga@
* group_ctx->name is only used in this one function, and for now itoga2008-05-181-7/+2
| | | | | | | | | | corresponds directly to the static list of group names. Just use the static list and stop strdup()ing a new version for the context struct. Since that never got freed this also fixes a small memleak. Kill some unused variables while i'm here. ok okan@
* KNF, no binary change.oga2008-05-151-3/+3
| | | | From Pierre Riteau. Thanks!
* Replace a few leftover calls to strdup and calloc with xstrdup and xcallocoga2008-04-161-1/+1
| | | | | | respectively. ok okan.
* Remove screen_infomsg(), nothing uses it.oga2008-04-161-8/+0
| | | | ok okan.
* hit it with the knf stick.oga2008-04-151-21/+21
|
* Replace the symlink configuration scheme with a simple yacc parser assimon2008-03-231-6/+0
| | | | | | | | | found in other places of the tree. Remove sticky and font commandline options and add another one for alternative config locations. Split off cwmrc(5) from cwm(1), nuke #ifdef __OpenBSD__ while there. tested by various kind people, feedback from oga@ and okan@ - thanks! ok oga@, jasper@, okan@
* allow autogrouping and sticky mode to work togetherokan2008-03-221-6/+6
| | | | ok oga@
* Rip out, burn, and dance around the grave of group-edit mode.oga2008-03-221-267/+8
| | | | | | | | | | | I've yet to speak to anyone who uses it, so just kill it. You can still add/remove from groups using the mouse binding. Groups may get a re-work sometime soon if i have a stroke of genius. knocks about 4k off the i386 binary for me. ok okan@, todd@.
* huge amount of cleanup and dead code removal.oga2008-01-161-26/+5
| | | | | | | | | | | | | | | | | | | | | | | | | full description of changes: -remove fontlist, and all associated structures/calls, it's not needed. this also removes any doubt about leftover 9wm code (the list was borrowed from it). Since cwm now uses Xft for everything, the legacy font handling is just not needed. -add /* FALLTHROUGH */ comments into grab_{label,menu}. I actually didn't intend grab_menu to be a fallthrough, but it actually works quite well there, so remove the extra rectangle drawing. I love it when that happens. -remove a couple of unused prototypes that were obviously missed before. -remove a bunch of commented out or if 0ed out code. It doesn't look to be coming back anytime soon. -several functions returned an int, but this was never checked. most of them only failed if they failed to grab the pointer (thus the internal state didn't change), so just make them void and return early if this is the case. -remove several unused functions and some useless variables. knocks something like 200bytes off the stripped binary size for me. ok marc@, tested by several others.
* Rewrite most of grab_menu in grab.c (it was partly 9wm code).oga2008-01-141-1/+1
| | | | | | | | | | | | | | | | | | | This should work functionally the same, with a few simplifications. Changes: - we don't care if you're holding another button when you release the menu key if you don't want to select anything, move off the menu. - remove the hysteresis from the menu selection (before you had to move more than three pixels onto a new menu entry before it selected it) - simplify a lot of the selection code - kill dead code. - do what the XXX comment said and cache the screensize (i may tweak this later). As far as I can tell, the only code remaining from 9wm is the list of fonts in calmwm.c. Others appear to concur. ok marc@, looked over and tested by a few others. Reminders from okan@.
* - Remove the "all rights reserved" tag at the top of most of the sourceoga2008-01-111-1/+12
| | | | | | | | | | | | | | | | | | files, and replace them with the actual ISC license. - add license to the manpage (it was lacking before) - correct license statement in the README Permission given by Marius (copyright holder): "1. please replace with the standard ISC license 2. you may add the ISC license to the man page 3. feel free to replace the information in the README as well" and Dros (copyright holder for group.c): "Please switch group.c to the ISC License." ok ian@
* convert globals from G_foo to Foo, as per TODO.jasper2007-05-281-74/+74
| | | | "looks good" pedro@, ok matthieu@
* Initial revisionbernd2007-04-271-0/+634