summary refs log tree commit diff
path: root/conf.c
Commit message (Collapse)AuthorAgeFilesLines
* cvsimportChristian Neukirchen2015-01-241-1/+1
|\
| * use malloc over calloc hereokan2015-01-231-1/+1
| |
* | cvsimportChristian Neukirchen2015-01-221-1/+2
|\|
| * Switch to limits.h; replace MAXPATHLEN and MAXHOSTNAMELEN with PATH_MAXokan2015-01-191-1/+2
| | | | | | | | | | | | and HOST_NAME_MAX+1, respectively. ok doug@
* | cvsimportokan2014-09-181-16/+17
|\|
| * these client actions are just toggles; less confusing with better namesokan2014-09-171-6/+6
| |
| * Implement EWMH _NET_WM_STATE_HIDDEN.okan2014-09-171-0/+1
| |
| * more style nitsokan2014-09-071-10/+10
| |
* | cvsimportChristian Neukirchen2014-09-071-53/+36
|\|
| * Move termpath and lockpath into cmdq; side effect is that 'lock' andokan2014-09-061-19/+11
| | | | | | | | 'term' now show up in the application menu.
| * Implement _NET_WM_STATE_STICKY, bound to CM-s by default; allows anyokan2014-08-251-0/+3
| | | | | | | | | | | | | | client to 'stick' to all desktops (ewmh speak) or groups - this currently has the same affect as setting a client's group to 'nogroup', with the exception that the client can also be in a group, so when un-sticking, the client will go back to its original group/desktop.
| * Continue effort to bring keyboard and mouse functions together; mergeokan2014-08-241-30/+20
| | | | | | | | name_to_kbfunc and name_to_mousefunc.
| * Purely mechanical; unify 'num', 'no' and 'shortcut'.okan2014-08-201-2/+2
| |
| * Remove unnecessary memset since reload was replaced with restart;okan2014-08-191-2/+0
| | | | | | | | from Kent Spillner.
* | cvsimportokan2014-04-211-0/+1
|\|
| * plug memleak (currently unused func); from Tiago Cunhaokan2014-04-211-0/+1
| |
* | cvsimportokan2014-02-021-11/+12
|\|
| * No need to store screen colormap and visual; rather just use the Xokan2014-02-021-6/+7
| | | | | | | | macros in the one place they are needed.
| * The menu already limits entries with MENU_MAXENTRY, so don't botherokan2014-02-021-5/+5
| | | | | | | | holding a command name limit as well.
* | cvsimportokan2014-01-301-29/+24
|\|
| * Switch ignoreq to winname struct since it's basically the same thing;okan2014-01-301-18/+13
| | | | | | | | removes limit on name matching.
| * use the same autogroupwin variable as everywhere elseokan2014-01-301-11/+11
| |
* | cvsimportokan2014-01-291-37/+61
|\|
| * Minimize trivial differences between a few kb and mb functions.okan2014-01-291-1/+1
| |
| * Merge keybinding and mousebinding queues into using the same mergedokan2014-01-291-23/+22
| | | | | | | | | | struct, binding; they were essentially the same accept for what was 'pressed', keysym or button.
| * Much like we do for keyboard and mouse bindings, remove duplicates forokan2014-01-291-0/+15
| | | | | | | | command name - last match.
| * Check command name/path for truncation and provide user feedback duringokan2014-01-291-13/+23
| | | | | | | | | | | | config parse (and use conf_cmd_add to populate defaults); based on a discussion with Tiago Cunha. While this looks ugly, there are likely some other changes here to come.
* | cvsimportokan2014-01-281-2/+4
|\|
| * Check ignore windowname for truncation and provide user feedback duringokan2014-01-281-2/+4
| | | | | | | | config parse; based on a discussion with Tiago Cunha.
* | cvsimportokan2014-01-241-4/+4
|\|
| * no need to quote within warningokan2014-01-231-2/+2
| |
| * Somewhat streamline event loop/restart/quit handling; most notableokan2014-01-221-2/+2
| | | | | | | | | | | | | | | | change allows a restart to trigger proper teardown first, even though teardown is not (yet) complete. After some discussion with oga@nicotinebsd.org regarding a more complicated version/idea.
* | cvsimportokan2014-01-211-148/+124
|\|
| * Sprinkle a few more const; from Tiago Cunha.okan2014-01-211-11/+11
| |
| * merge KBFLAG_NEEDCLIENT and MOUSEBIND_CTX_*; brings kbfunc and mousefuncokan2014-01-201-68/+53
| | | | | | | | bits even closer.
| * Use argument to pass down flags for mousefunc cyclegroup; removesokan2014-01-201-3/+4
| | | | | | | | rcyclegroup wrapper need - now similar to kbfunc.
| * constify and rename some confusing variables around cmdq.okan2014-01-201-9/+9
| |
| * - remove redundant range check for buttons in conf_bind_mouse.okan2014-01-201-61/+51
| | | | | | | | | | | | | | | | | | - make conf_bind_kbd return error on non-matches to match what conf_bind_mouse does. - rename some variables while here for clarity. - constify bind and cmd. from Tiago Cunha.
* | cvsimportokan2014-01-031-8/+8
|\|
| * use consistent typesokan2014-01-031-8/+8
| |
* | cvsimportokan2014-01-031-14/+17
|\|
| * bring mousefunc closer to kbfuncokan2014-01-021-14/+17
| |
* | cvsimportokan2013-12-171-1/+1
|\|
| * replace with memsetokan2013-12-171-1/+1
| |
* | cvsimportokan2013-12-161-1/+4
|\|
| * Implement support for EWMH's _NET_WM_STATE_FULLSCREEN hint.okan2013-12-161-1/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Since we already have a form of 'maximize', we need to differentiate between 'maximize' and the new 'fullscreen' mode. The 'maximize' mode will continue to honor gap but now *retains* the border, matching the 'vert/horz maximize' behaviour. The new 'fullscreen' mode supports and follows the _NET_WM_STATE_FULLSCREEN hint, allowing the client perform additional window modifications; in this mode, cwm(1) will *ignore* gap, remove borders and freeze(move/resize) the client. Additionally, 'fullscreen' mode will remember various combinations of previous states. * default keybinding changes: CM-f 'fullscreen', CM-m 'maximize' (re-map as desired). Positive feedback from a few, testing and ok sthen@
* | cvsimportokan2013-12-131-0/+2
|\|
| * Add support for XUrgency and matching _NET_WM_STATE_DEMANDS_ATTENTIONokan2013-12-131-0/+2
| | | | | | | | | | | | | | ewmh hint; urgencyborder is configurable. The urgency flag will stick, even while on a client in a non-viewable group, until the client receives focus (where the border is reset). Initial diff from Thomas Adam with some changes/enhancements from me.
* | cvsimportokan2013-12-021-14/+4
|\|
| * like gap, make snapdist per screenokan2013-11-271-0/+1
| |