about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorbernd <bernd>2007-04-27 17:58:48 +0000
committerbernd <bernd>2007-04-27 17:58:48 +0000
commit3d12c94f42f91e957fa8a68efcd3b0387791e6cf (patch)
tree8bd9782a01bbd59ee27201e29b30d058b15445db /Makefile.am
downloadcwm-3d12c94f42f91e957fa8a68efcd3b0387791e6cf.tar.gz
cwm-3d12c94f42f91e957fa8a68efcd3b0387791e6cf.tar.xz
cwm-3d12c94f42f91e957fa8a68efcd3b0387791e6cf.zip
Initial revision
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..37205b5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,19 @@
+include $(top_srcdir)/Makefile.am.inc
+
+CC = gcc
+
+man_MANS = cwm.1
+
+bin_PROGRAMS = cwm
+
+cwm_DEPENDENCIES = @ERRO@ @LIBOBJS@
+cwm_SOURCES = calmwm.c draw.c screen.c xmalloc.c client.c grab.c \
+	      search.c util.c  xutil.c conf.c input.c xevents.c \
+	      group.c geographic.c kbfunc.c cursor.c font.c
+cwm_LDADD = @ERRO@ @LIBOBJS@ $(XFT_LIBS)
+
+AM_CFLAGS = -Wall -Icompat $(XFT_CFLAGS)
+
+EXTRA_DIST = LICENSE README cwm.1 strlcpy.c err.c Makefile.am.inc	\
+             compat/sys/queue.h compat/sys/tree.h hash.h calmwm.h	\
+             headers.h strlcat.c